ecobee

My thermostat is not connecting to ecobee servers, what should I do?

This article is applicable to the ecobee3, ecobee3 lite and ecobee 4

 

If your ecobee is connected to your home network but is unable to connect to ecobee servers, there may be some channel hopping going on or some specific security settings on your router. To check if your ecobee is connected to ecobee servers, go to MAIN MENU > ABOUT > WI-FI > CONNECTED TO ECOBEE.COM.

 

Troubleshooting:

1) Try power-cycling the ecobee by removing it from the wall and leaving it off for two minutes

2) After two minutes, place the ecobee back on the wall

3) To reconnect to Wi-Fi, go to MAIN MENU > SETTINGS > WI-FI > NETWORK > SELECT WI-FI NETWORK. Choose your home network from the list and wait for the ecobee to reconnect

4) If your ecobee does not connect to Wi-Fi after following the steps above, try connecting to a mobile hotspot.

 

If you’re able to connect to a hotspot but not to your Wi-Fi network, this may be due to a security setting on your router such as a firewall or blocked port. Try setting your security settings to medium/low and check with your ISP to confirm that ports 8190 and 8089 are unblocked.

 

If you still experience issues connecting to ecobee servers after following the above troubleshooting steps, please contact our Support team at 1-877-932-6233. Agents are available from 8:00AM – 12:00AM EST Monday through Friday and 9:00AM – 9:00PM Saturday through Sunday.

Was this article helpful?

Have more questions? Submit a request