ecobee

Verifying Thermostat firmware version

To accomodate the ZigBee HA module the thermostat firmware version must be 2.4.0.339 or higher. The firmware version can be checked one of two ways:

  1. On the thermostat, select More > Settings > About > Version > ecobee Smart
  2. From the web portal select Settings tab > open the About widget > click on the Version tab > Thermostat Software version

Was this article helpful?

Have more questions? Submit a request