Help! Alexa says she is having troubles connecting to my Wi-Fi.

Let's figure it out. First, check if your Switch+ is connected to your Wi-Fi and the ecobee server. Press and hold the mute on the top of your Switch+ for 7 seconds (this launches a network diagnosis) and wait for the voice prompt to indicate whether your Switch+ is connected to Wi-Fi and the ecobee servers. If your Switch+ isn't connected, follow the steps below:

  1. Press and hold the main button for 5 seconds
  2. Wait for the voice prompt to say "Reset to factory settings."
  3. Press the main button again
  4. Wait for the amber light to illuminate (about 30 seconds)
  5. Retry registration using the ecobee app.

If the voice prompt tells you that your Switch+ is connected, or if you're still having trouble connecting after resetting and reregistering, you may need to improve your connection. There's lots of ways to improve your connection, but these are the top 5 reasons you might be experiencing issues:

  1. Distance: The greater the distance between devices, the worse the signal. Try moving your router closer to your ecobee Switch+.
  2. Obstructions: Sometimes the Wi-Fi signal gets reflected, refracted or absorbed by common objects in your home, including cabinets, mirrors or glass, metal objects, even thick walls. See if you can clear the obstruction, or simply move your router closer to your Switch+.
  3. Wireless Interferences: In some cases, your signal could be interfered by neighbouring wireless networks, microwave ovens, Bluetooth® devices or baby monitors. To solve this, change the channel and SSID on your router. Try channels 1, 6, 9 or 11 (they're non-overlapping channels).
  4. Outdated firmware on your router: When was the last time you upgraded your router's firmware? Or your router? Try upgrading the firmware of your router, and see if it improves your signal.
  5. Power interruptions: If you're unable to find a wireless signal after a power outage, you may need to powercycle your router. To do this, unplug your router, wait 10 seconds and plug it back in again. If this doesn't solve the problem, you may need to reset your router and wait for it to boot up again.

We also recommend running a speed test on your Wi-Fi network. If you find that the it's low, try contacting your network supplier and have them assist with speeding up your network.


If you're still experiencing problems, please contact ecobee support: 

1.877.932.6233 (Toll free)

1.647.428.2220 (International)

email us:

Was this article helpful?

Have more questions? Submit a request